In my last post I told you about the CCIE Voice 3.0 lab that I am building.

Well as I will keep refering to this diagram–>   ccie-voice-vmware-gns3-diagram-1.0 just make a print of this and keep this as a hardcopy.

ccie-voice-vmware-gns3-diagram-1.0

Today I will be showing you my configuration for all of the sites that are in the diagram. Because my sources (Blindhog & jayanm) did not posted full configuration examples for this lab and their setup is kind of outdated (as from the day I am writing this) I will post some full configuration with some explanation added to it, so it will be easier for you to set this up more easaly without loosing time.

HQ – hq-3725

host hq-3725
!this router is configured as a gateway on the callmanager itself
voice service voip
allow-connections h323 to h323
!
interface Loopback0
ip address 10.11.1.254 255.255.255.255
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.11.1.254
!
interface FastEthernet0/0
ip address 10.11.11.135 255.255.255.0
speed 100
full-duplex
!
interface FastEthernet0/1
ip address 10.255.255.135 255.255.255.0
speed 100
full-duplex
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
!
interface Serial0/0.1 point-to-point
 ip address 10.254.254.1 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 101
!
interface Serial0/0.2 point-to-point
 ip address 10.254.254.5 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 102
!
router ospf 1
!Frame relay links are advertised in OSPF
network 10.200.1.0 0.0.0.255 area 0
network 10.200.2.0 0.0.0.255 area 0
!also specify the LAN network in OSPF
network 10.11.11.0 0.0.0.255 area 0
!
!all numbers that not known from the headquarter are routed to the PSTN router
!because this site is comfigured as a peer within the callmanager all known numbers will router automatically to the callmanager
dial-peer voice 1 voip
destination-pattern .T
session target ipv4:10.255.255.254
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
!if you call 1011111... this number will be directed to the callmanager
dial-peer voice 2010 voip
destination-pattern 1011111...
!this is callmanagers IP address
session target ipv4:10.11.11.137
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
gateway

RS1 – rs1-3725

host rs1-3725
!this router is configured as a gateway on the callmanager itself
voice service voip
allow-connections h323 to h323
!
interface Loopback0
ip address 10.12.1.254 255.255.255.255
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.12.1.254
!
interface FastEthernet0/0
ip address 10.11.12.254 255.255.255.0
speed 100
full-duplex
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
!
interface Serial0/0.1 point-to-point
 ip address 10.254.254.2 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 202
!
router ospf 1
!Frame relay link are advertised in OSPF
network 10.200.1.0 0.0.0.255 area 0
!
!also specify the LAN network in OSPF
network 10.11.12.0 0.0.0.255 area 0
!
!all numbers that not known from the headquarter are routed to the PSTN router
!because this site is configured as a peer within the callmanager all known numbers will router automatically to the callmanager
dial-peer voice 1 voip
destination-pattern .T
session target ipv4:10.255.255.254
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad

RS2 - rs2-3725

host rs2-3725
!this router is configured as a gateway on the callmanager itself
voice service voip
allow-connections h323 to h323
!
interface Loopback0
ip address 10.13.1.254 255.255.255.255
h323-gateway voip interface
h323-gateway voip bind srcaddr 10.13.1.254
!
interface FastEthernet0/0
ip address 10.11.13.254 255.255.255.0
speed 100
full-duplex
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 clock rate 2000000
!
interface Serial0/0.1 point-to-point
 ip address 10.254.254.6 255.255.255.252
 snmp trap link-status
 frame-relay interface-dlci 203
!
router ospf 1
!Frame relay link are advertised in OSPF
network 10.200.1.0 0.0.0.255 area 0
!also specify the LAN network in OSPF
network 10.13.1.0 0.0.0.255 area 0
!
!all numbers that not known from the headquarter are routed to the PSTN router
!because this site is configured as a peer within the callmanager all known numbers will router automatically to the callmanager
dial-peer voice 1 voip
destination-pattern .T
!this is the PSTNSIM IP address
session target ipv4:10.255.255.254
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad

PSTN - pstn-3725

host pstn-3725
!make sure all the sites are in the same VLANS for PSTN communication
interface FastEthernet0/0
 switchport
 switchport mode access
 switchport access vlan 20
 no shut
!
!make sure all the sites are in the same VLANS for PSTN communication
interface FastEthernet0/1
 switchport
 switchport mode access
 switchport access vlan 20
 no shut
!
!make sure all the sites are in the same VLANS for PSTN communication
interface FastEthernet0/2
 switchport
 switchport mode access
 switchport access vlan 20
 no shut
!
interface vlan 20
 ip address 10.255.255.254 255.255.255.0
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.255.255.254
 no shut
!
tftp-server flash:P00307020200.bin
tftp-server flash:P00307020200.loads
tftp-server flash:P00307020200.sb2
tftp-server flash:P00307020200.sbn
!
ip route 10.11.11.0 255.255.255.0 10.255.255.135
ip route 10.11.12.0 255.255.255.0 10.255.255.11
ip route 10.11.13.0 255.255.255.0 10.255.255.12
!
!
!When someone calls from the PSTN phone to 1011111...the call is directed to the HQ and the HQ will send it to the Callmanager
dial-peer voice 1000 voip
destination-pattern 1011111...
session target ipv4:10.11.1.254
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
!When someone calls from the PSTN phone to 2022222...the call is directed to the RS1 and a phone will be configured on this site to handle
calls
dial-peer voice 2000 voip
destination-pattern 2022222...
session target ipv4:10.12.1.254
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
!When someone calls from the PSTN phone to 3033333... the call is directed to the RS2 and a phone will be configured on this site to handle calls
dial-peer voice 3000 voip
destination-pattern 3033333...
session target ipv4:10.13.1.254
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
!This is where you say this is a IP network (for PSTN it would be POTS)
dial-peer voice 1 voip
!this is that all incomming numbers will be forwarded to the pstn phone
incoming called-number .
dtmf-relay h245-alphanumeric
codec g711ulaw
no vad
!
telephony-service
load 7960-7940 P00307020200
max-ephones 1
max-dn 5
ip source-address 10.255.255.254 port 2000
!
!these are the 5 numbers that are going to be terminated at the PSTN PHONE
ephone-dn 1 dual-line
number 911
!
ephone-dn 2 dual-line
number 1015551111
!
ephone-dn 3 dual-line
number 2025552222
!
ephone-dn 4 dual-line
number 3035553333
!
ephone-dn 5 dual-line
number 55987654321
!
!This is the PSTN phone itself
ephone 1
mac-address 0000.0000.0000
type 7960
button 1:1 2:2 3:3 4:4 5:5
!
gateway

Next time I will show you a video with a demonstration of how everything is set up and how it´s working together.

This means that we are actually going to make some real calls accross with the softphones and the dynamips routers in combination with the Callmanager that is running on VMware.

Have fun with the configuration and if you have questions or remarks please contact me… I would be more than happy to help you!